hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2843) Rename protobuf message StorageInfoProto to NodeInfoProto
Date Fri, 27 Jan 2012 18:26:10 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13194979#comment-13194979
] 

Suresh Srinivas commented on HDFS-2843:
---------------------------------------

bq. it's still information that's specific to "storage" in the general sense, although it's
not specific to a single storage directory
This information is used by secondary namenode, checkpointer, backup node as well. Does that
still make it "storage"?

bq. That said, what about during a distributed upgrade process which will change the layoutVersion?
Distributed upgrade was used only once long back and is not in use any more. It is the regular
upgrade that considers layout version and CTime etc.

bq. Imagine a scenario where a DN dies during an upgrade while writing the VERSION files to
its various storage directories, and hence only some subset of the directories get the updated
VERSION file. Would we then need to know what layoutVersion is present in each storage directory
separately? I haven't checked on how this case is handled - just thinking out loud.

I am not proposing any change in the VERSION file. All I am saying is, call this part NodeInfo
instead of StorageInfo. All this information is still present in all the data structures.
I plan to cleanup the hierarchy of classes where StorageInfo is super class of bunch of other
classes such DataStorage, BlockPoolSliceStorage, Storage etc.
                
> Rename protobuf message StorageInfoProto to NodeInfoProto
> ---------------------------------------------------------
>
>                 Key: HDFS-2843
>                 URL: https://issues.apache.org/jira/browse/HDFS-2843
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HDFS-2843.patch
>
>
> StorageInfoProto has cTime, layoutVersion, namespaceID and clusterID. This is really
information of a node that is part of the cluster, such as Namenode, Standby/Secondary/Backup/Checkpointer
and datanodes. To reflect this, I want to rename it as NodeInfoProto from StorageInfoProto.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message