hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2843) Rename protobuf message StorageInfoProto to NodeInfoProto
Date Thu, 26 Jan 2012 20:17:41 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13194159#comment-13194159
] 

Aaron T. Myers commented on HDFS-2843:
--------------------------------------

Hey Suresh, I'm not convinced that this name change is appropriate. I agree that most of this
information should not differ between storage directories on a single node, but some of the
information is still storage-specific (e.g. layoutVersion), and the information is mostly
used to compare storage versions between nodes. Given this, the current name seems appropriate
to me. I could probably be convinced otherwise, though.

Regardless, if we do go ahead with a name change, it doesn't make sense to me that we would
change StorageInfoProto but not StorageInfo itself, given that StorageInfoProto is really
just a serialization class of StorageInfo. If the semantic of the name StorageInfoProto is
wrong, then surely StorageInfo is as well, right?
                
> Rename protobuf message StorageInfoProto to NodeInfoProto
> ---------------------------------------------------------
>
>                 Key: HDFS-2843
>                 URL: https://issues.apache.org/jira/browse/HDFS-2843
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HDFS-2843.patch
>
>
> StorageInfoProto has cTime, layoutVersion, namespaceID and clusterID. This is really
information of a node that is part of the cluster, such as Namenode, Standby/Secondary/Backup/Checkpointer
and datanodes. To reflect this, I want to rename it as NodeInfoProto from StorageInfoProto.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message