hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2805) HA: Add a test for a federated cluster with HA NNs
Date Wed, 25 Jan 2012 19:49:40 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2805?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13193252#comment-13193252

Aaron T. Myers commented on HDFS-2805:

Thanks a lot for providing a patch for this issue, Brandon. A few comments:

# simpleHAFederatedTopology - Perhaps the name service and NN numbering should start at 0,
instead of 1? There's no reason it can't start at 0, and I'd prefer to be as consistent as
possible. (Most of the HA tests start at 0, not 1.)
# configureFailoverFs - should use javadoc-style method comment with @param tags.
# configureFailoverFs - rather than duplicating the code in the configuredFailoverFs which
doesn't take a nameservice index, you should implement the other in terms of the one which
does take a name service index.
# setFailoverConfigurations - you added another parameter without updating all callers of
the method, so TestBalancerWithHANameNodes no longer compiles. You should either update the
caller or add another HATestUtil#setFailoverConfigurations method which defaults to the first
name service. I probably prefer the latter.
# MiniDFSCluster#createNameNodesAndSetConf - since you moved the aggregation of the list of
nameservice IDs higher in the method, there's no need for the nsIds list lower in the method.
# testManualFOFB - I don't like that the log messages will say "failing over to NN 3", etc
when we're testing the failover of a higher name service ID. I'd much prefer "failing over
to NN 1 in name service 2", for example.
# testManualFOFB - no need to abbreviate this method name, and it's not at all obvious what
it stands for, especially since the method comment just says "test manual fofb"
# testManualFOFB - pleause use a javadoc-style method comment, and put a blank line between
methods in a class.
# testManualFOFB - please put spaces around arithmetic operators "+" and "*".
> HA: Add a test for a federated cluster with HA NNs
> --------------------------------------------------
>                 Key: HDFS-2805
>                 URL: https://issues.apache.org/jira/browse/HDFS-2805
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ha, name-node
>    Affects Versions: HA branch (HDFS-1623)
>            Reporter: Aaron T. Myers
>            Assignee: Brandon Li
>         Attachments: HDFS-2805.3.txt, HDFS-2805.second.txt, HDFS-2805.txt
> Add a test for configuring/interacting with a federated cluster wherein each name service
is itself HA.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message