hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2843) Rename protobuf message StorageInfoProto to NodeInfoProto
Date Thu, 26 Jan 2012 15:26:38 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13193898#comment-13193898
] 

Hadoop QA commented on HDFS-2843:
---------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12511984/HDFS-2843.patch
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 3 new or modified tests.

    -1 javadoc.  The javadoc tool appears to have generated 21 warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 eclipse:eclipse.  The patch built with eclipse:eclipse.

    -1 findbugs.  The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit
warnings.

    +1 core tests.  The patch passed unit tests in .

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1817//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/1817//artifact/trunk/hadoop-hdfs-project/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1817//console

This message is automatically generated.
                
> Rename protobuf message StorageInfoProto to NodeInfoProto
> ---------------------------------------------------------
>
>                 Key: HDFS-2843
>                 URL: https://issues.apache.org/jira/browse/HDFS-2843
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HDFS-2843.patch
>
>
> StorageInfoProto has cTime, layoutVersion, namespaceID and clusterID. This is really
information of a node that is part of the cluster, such as Namenode, Standby/Secondary/Backup/Checkpointer
and datanodes. To reflect this, I want to rename it as NodeInfoProto from StorageInfoProto.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message