hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William McNeill (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2662) Namenode should log warning message when trying to start on a unformmatted system
Date Sun, 18 Dec 2011 23:18:31 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2662?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13171954#comment-13171954
] 

William McNeill commented on HDFS-2662:
---------------------------------------

I verified that if I delete the DFS directory (/tmp/hadoop-williammcneill/dfs on my machine)
and run start-dfs.sh I get just the SCDynamicStore error message in the DFS log, but the namenode
is not running. If I then run "hadoop namenode -format" and re-run start-dfs.sh the log file
is the same--just the SCDynamicStore error message--but the namenode is now running and HDFS
operations work.

I'll double-check the Kerberos workaround discussed in Jira 7489, but I think that's an unrelated
issue since you see the warning message regardless of whether the namenode is running.
                
> Namenode should log warning message when trying to start on a unformmatted system
> ---------------------------------------------------------------------------------
>
>                 Key: HDFS-2662
>                 URL: https://issues.apache.org/jira/browse/HDFS-2662
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>    Affects Versions: 0.20.203.0
>         Environment: Single-node cluster on OS X 10.7 (Lion)
>            Reporter: William McNeill
>            Priority: Minor
>              Labels: format, logging, namenode
>
> When you try to start the namenode for a system that does not have a formatted DFS, it
fails silently without any indication that the lack of formatting was the problem. I tried
to run start-dfs.sh on a single-node cluster with an unformatted HDFS. The namenode failed
to start, but generated no warning messages, and its log was empty. After running "hadoop
namenode -format" everything worked.
> Details in this thread: http://mail-archives.apache.org/mod_mbox/hadoop-common-user/201112.mbox/%3CCAN9z%2BopAn-t_f3FRC%3DDtV0n0ysoKd3Fek-fJPb68PMThiPooKg%40mail.gmail.com%3E
> This is a difficult problem to diagnose because the namenode gives you no feedback. It
would be better if it printed an error message to its log file.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message