hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2316) webhdfs: a complete FileSystem implementation for accessing HDFS over HTTP
Date Fri, 04 Nov 2011 21:39:52 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13144367#comment-13144367

Tsz Wo (Nicholas), SZE commented on HDFS-2316:

1. Agree, symlink could be optional.  BTW, the "isDir" and "isSymlink" are replaced with "type",
which is an enum {FILE, DIRECTORY, SYMLINK}

2. Sure.  Let's change it in a separated JIRA then.

3. Path is a parameter value, therefore case sensitive.

I think case sensitive causes more confusion:

Q: Why this is not working?  http://nn:port/webhdfs/v1/path?Op=GETFILECHECKSUM
A: You must use lower case: "Op" should be "op"

Q: Why this is not working?  http://nn:port/webhdfs/v1/path?op=GETFILECHECKSUM&does=nicholas
A: It is a typo: "does" should be "doas".
Q: But "doas" looks more like a typo than "does".  I wish I can use "doAs"

How about op values and boolean values?  Do you also think that they should be case sensitive?

4. "name" should like file/directory names.  "localName" is an empty string if the full path
is given.  How about calling it "pathSuffix"?

5. As Arpit mentioned, the payload for liststatus won't be increased significantly.  We only
needs two more words per request (instead of one more word per status.)

Is Hoop going to support file system other than HDFS?

It is common to convert JSON to/from XML.  We should make the convertion trivial.

6. Webhdfs and hoop should not share the same scheme since they require different implementatons.
 Webhdfs should use "webhdfs://".  For hoop, I suggest not using "http://" as a file system

> webhdfs: a complete FileSystem implementation for accessing HDFS over HTTP
> --------------------------------------------------------------------------
>                 Key: HDFS-2316
>                 URL: https://issues.apache.org/jira/browse/HDFS-2316
>             Project: Hadoop HDFS
>          Issue Type: New Feature
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: WebHdfsAPI20111020.pdf, WebHdfsAPI20111103.pdf
> We current have hftp for accessing HDFS over HTTP.  However, hftp is a read-only FileSystem
and does not provide "write" accesses.
> In HDFS-2284, we propose to have webhdfs for providing a complete FileSystem implementation
for accessing HDFS over HTTP.  The is the umbrella JIRA for the tasks.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message