hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-1055) Improve thread naming for DataXceivers
Date Thu, 24 Nov 2011 00:44:40 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1055?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Konstantin Shvachko updated HDFS-1055:
--------------------------------------

    Fix Version/s: 0.22.0
    
> Improve thread naming for DataXceivers
> --------------------------------------
>
>                 Key: HDFS-1055
>                 URL: https://issues.apache.org/jira/browse/HDFS-1055
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>    Affects Versions: 0.22.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>             Fix For: 0.22.0
>
>         Attachments: dataxceiver-merged.patch, dataxceiver.patch, hdfs-1055-1.patch,
hdfs-1055-branch20.txt
>
>
> The DataXceiver threads are named using the default Daemon naming, which is Runnable.toString().
Currently this isn't implemented, so threads have names like org.apache.hadoop.hdfs.server.datanode.DataXceiver@579c9a6b.
It would be very handy for debugging (and even ops maybe) to have a better name like "DataXceiver
for client 1.2.3.4 [reading block_234254242]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message