hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HDFS-111) UnderReplicationBlocks should use generic types
Date Mon, 21 Nov 2011 13:48:51 GMT

     [ https://issues.apache.org/jira/browse/HDFS-111?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Harsh J resolved HDFS-111.
--------------------------

    Resolution: Not A Problem

Both comments seem to have been addressed already today. Not a problem anymore, resolving.
                
> UnderReplicationBlocks should use generic types
> -----------------------------------------------
>
>                 Key: HDFS-111
>                 URL: https://issues.apache.org/jira/browse/HDFS-111
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Konstantin Shvachko
>            Priority: Minor
>
> 1. HADOOP-659 introduced new class UnderReplicationBlocks, and
> two new warnings about use of generic types
>         TreeSet<Block>[] priorityQueues = new TreeSet[LEVEL];
>         Iterator<Block>[] iterator = new Iterator[LEVEL];
> should resp. read
>         TreeSet<Block>[] priorityQueues = new TreeSet<Block>[LEVEL];
>         Iterator<Block>[] iterator = new Iterator<Block>[LEVEL];
> 2. I'd rename class UnderReplicationBlocks to UnderReplicatedBlocks while it is still
internal.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message