hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2158) Add JournalSet to manage the set of journals.
Date Wed, 28 Sep 2011 22:08:45 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13116850#comment-13116850

Suresh Srinivas commented on HDFS-2158:

Comments (some are directly not related to this changes in this patch):
# JournalSet.java
#* #remove() #getEditLogManifest() should not throw IOException
#* Add javadoc comments to the methods where it is missing
#* Why do you need method level @VisibleForTesting when you have it the class level?
#* JournalClosure - add /** */ class javadoc to class and method 
#* JounrnalSetOutputStream - add class javadoc
#* JournalSet#getOuputStream() is not used any where
# JournalManager please update the class javadoc, because with JournalSet it no longer holds
# FSEditLog.java
#* My preference is to leave import of FSEditLogOp.*
#* Remove commented NO_JOURNAL_STREAMS_WARNING if it not required
#* FSEditLog constructor must not throw IOException
#* logSyncAll() should not throw IOException
#* logGetDelgationToken() remove @return
#* make FSEditLog#journalSet final
#* logSyn() has some indentation issues
#* You can get rid of log of LOG.error("All journal have failed ...") by putting it is in
# EditLogBackupOutputStream - remove LOG.info() which is not necessary
# EditLogOutputStream.java - has many unused imports and consturctor should not throw IOException
# TestStorageRestore.java - remove unused Writable import

Unrelated to this patch, to address in a different jira:
# JournalManager.java
#* Jounrnal manager class javadoc should mention that txid are sequential and no gaps are
#* startLogSegment() - better name would be openNewLogSegment(), finalizeLogSegment could
be closeLogSegment
#* purgeLogsOlderThan() the method javadoc says minImageTxId instead of minTxIdToKeep
#* Please more comments to recoverFinalizedSegments() - It should mention details of recovery
#* "is cannot be" to "cannot be"

> Add JournalSet to manage the set of journals.
> ---------------------------------------------
>                 Key: HDFS-2158
>                 URL: https://issues.apache.org/jira/browse/HDFS-2158
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Jitendra Nath Pandey
>            Assignee: Jitendra Nath Pandey
>         Attachments: HDFS-2158.1.patch, HDFS-2158.10.patch, HDFS-2158.3.patch, HDFS-2158.4.patch,
HDFS-2158.8.patch, HDFS-2158.9.patch
> The management of the collection of journals can be encapsulated in a JournalSet. This
will cleanup the FSEditLog code significantly.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message