hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2323) start-dfs.sh script fails for tarball install
Date Tue, 13 Sep 2011 00:11:09 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13103204#comment-13103204
] 

Aaron T. Myers commented on HDFS-2323:
--------------------------------------

+1, the patch looks good to me. I reviewed the code and also tested the script per Tom's instructions,
and it worked like a charm.

It might be worth noting somewhere that even with this patch, the start-dfs.sh script will
not work without first overlaying the Common and HDFS target directories.

> start-dfs.sh script fails for tarball install
> ---------------------------------------------
>
>                 Key: HDFS-2323
>                 URL: https://issues.apache.org/jira/browse/HDFS-2323
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Tom White
>            Assignee: Tom White
>         Attachments: HDFS-2323.patch
>
>
> I build Common and HDFS tarballs from trunk then tried to start a cluster with start-dfs.sh,
but I got the following error:
> {noformat}
> Starting namenodes on [localhost ]
> sbin/start-dfs.sh: line 55: /Users/tom/tmp/hadoop/libexec/../bin/hadoop-daemons.sh: No
such file or directory
> sbin/start-dfs.sh: line 68: /Users/tom/tmp/hadoop/libexec/../bin/hadoop-daemons.sh: No
such file or directory
> Starting secondary namenodes [0.0.0.0 ]
> sbin/start-dfs.sh: line 88: /Users/tom/tmp/hadoop/libexec/../bin/hadoop-daemons.sh: No
such file or directory
> {noformat}

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message