hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2371) Refactor BlockSender.java for better readability
Date Wed, 28 Sep 2011 06:58:46 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2371?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13116247#comment-13116247
] 

Hadoop QA commented on HDFS-2371:
---------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12496842/HDFS-2371.txt
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit
warnings.

    -1 core tests.  The patch failed these unit tests:
                  org.apache.hadoop.hdfs.server.datanode.TestReplicasMap
                  org.apache.hadoop.hdfs.server.blockmanagement.TestHost2NodesMap
                  org.apache.hadoop.hdfs.TestFileAppend2
                  org.apache.hadoop.hdfs.TestDfsOverAvroRpc

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1309//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1309//console

This message is automatically generated.
                
> Refactor BlockSender.java for better readability
> ------------------------------------------------
>
>                 Key: HDFS-2371
>                 URL: https://issues.apache.org/jira/browse/HDFS-2371
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>            Reporter: Suresh Srinivas
>             Fix For: 0.24.0
>
>         Attachments: HDFS-2371.txt, HDFS-2371.txt, HDFS-2371.txt
>
>
> BlockSender.java is hard to read and understand. I propose refactoring it for better
readability

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message