hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-2273) Refactor BlockManager.recentInvalidateSets to a new class
Date Sat, 20 Aug 2011 23:08:27 GMT

     [ https://issues.apache.org/jira/browse/HDFS-2273?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tsz Wo (Nicholas), SZE updated HDFS-2273:
-----------------------------------------

    Attachment: h2273_20110820.patch

Eric, thanks for the review.

h2273_20110820.patch:

> The invalidateWorkForOneNode() method exists in both InvalidateBlocks.java and BlockManager.java.
I found that confusiong at first. Would it be practical to change the name of one of them?

Rename the one in InvalidateBlocks to invalidateWork.

> InvalidateBlocks.add(): In the call to NameNode.stateChangeLog.info(), "addToInvalidates"
is hard-coded in the output string. I think it should be something like "InvalidateBlocks.add"
or just "add".

Done.

> In the JavaDocs for addToInvalidates(), the @param definitions got removed.  

The javadoc was
{code}
-   * @param b block
-   * @param dn datanode
{code}
I removed them since I renamed the parameters: b to block and dn to datanode.

> Shouldn't the methods in InvalidateBlocks have @param tags where applicable? For e.g.,
the add() method only has the log @param.

Since this is a private API (just have added @InterfaceAudience.Private) and the meaning of
the parameters are clear.  I think @param tags are unnecessary.

> Refactor BlockManager.recentInvalidateSets to a new class
> ---------------------------------------------------------
>
>                 Key: HDFS-2273
>                 URL: https://issues.apache.org/jira/browse/HDFS-2273
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>         Attachments: h2273_20110818.patch, h2273_20110818b.patch, h2273_20110820.patch
>
>
> recentInvalidateSets and the associated methods can be moved out from BlockManager.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message