hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Payne (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2273) Refactor BlockManager.recentInvalidateSets to a new class
Date Fri, 19 Aug 2011 21:35:29 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2273?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13087992#comment-13087992

Eric Payne commented on HDFS-2273:

* The invalidateWorkForOneNode() method exists in both InvalidateBlocks.java and BlockManager.java.
I found that confusiong at first. Would it be practical to change the name of one of them?
* InvalidateBlocks.add(): In the call to NameNode.stateChangeLog.info(), "addToInvalidates"
is hard-coded in the output string. I think it should be something like "InvalidateBlocks.add"
or just "add".
* In the JavaDocs for addToInvalidates(), the @param definitions got removed.
* Shouldn't the methods in InvalidateBlocks have @param tags where applicable? For e.g., the
add() method only has the log @param.
* I usually don't like to synchronize entire methods since it causes blocking for longer than
strictly necessary when compared with only synchronizing the affected variables within the
method. However, in this case, the methods are small enough that most of each method would
need to be synchronized anyway.

> Refactor BlockManager.recentInvalidateSets to a new class
> ---------------------------------------------------------
>                 Key: HDFS-2273
>                 URL: https://issues.apache.org/jira/browse/HDFS-2273
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>         Attachments: h2273_20110818.patch, h2273_20110818b.patch
> recentInvalidateSets and the associated methods can be moved out from BlockManager.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message