hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2195) Refactor StorageDirectory to not be an non-static inner class
Date Fri, 05 Aug 2011 08:36:36 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2195?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13079841#comment-13079841
] 

Hudson commented on HDFS-2195:
------------------------------

Integrated in Hadoop-Hdfs-trunk #738 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/738/])
    HDFS-2195. Refactor StorageDirectory to not be an non-static inner class. Contributed
by Todd Lipcon

eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1151707
Files : 
* /hadoop/common/trunk/hdfs/CHANGES.txt
* /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/UpgradeUtilities.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceStorage.java
* /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/TestDFSUpgradeFromImage.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/datanode/DataStorage.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/FSImage.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/NNStorage.java
* /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestClusterId.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/common/Storage.java
* /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/BackupImage.java


> Refactor StorageDirectory to not be an non-static inner class
> -------------------------------------------------------------
>
>                 Key: HDFS-2195
>                 URL: https://issues.apache.org/jira/browse/HDFS-2195
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node, name-node
>    Affects Versions: 0.23.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-2195.txt, hdfs-2195.txt
>
>
> While working on HDFS-1073 I continually found it inconvenient that StorageDirectory
is a non-static inner class of Storage. This makes testing more complicated, and also has
unintuitive results, like {{sd.read()}} having side effects on a Storage object.
> I'd like to try to make it a static inner class so that these side effects are clearer
and it's easier to use in isolation.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message