hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2195) Refactor StorageDirectory to not be an non-static inner class
Date Tue, 26 Jul 2011 00:51:09 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2195?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13070879#comment-13070879
] 

Eli Collins commented on HDFS-2195:
-----------------------------------

Why does StorageDirectory need to be an inner-class?  Given that it's referenced by a bunch
of classes and it looks like Storage's private members (eg STORAGE_*, StorageState) actually
belong in StorageDirectory it seems like it might be better in an independent namespace.

> Refactor StorageDirectory to not be an non-static inner class
> -------------------------------------------------------------
>
>                 Key: HDFS-2195
>                 URL: https://issues.apache.org/jira/browse/HDFS-2195
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node, name-node
>    Affects Versions: 0.23.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-2195.txt
>
>
> While working on HDFS-1073 I continually found it inconvenient that StorageDirectory
is a non-static inner class of Storage. This makes testing more complicated, and also has
unintuitive results, like {{sd.read()}} having side effects on a Storage object.
> I'd like to try to make it a static inner class so that these side effects are clearer
and it's easier to use in isolation.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message