hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-1979) HDFS-1073: Fix backupnode for new edits/image layout
Date Wed, 13 Jul 2011 19:41:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1979?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13064800#comment-13064800

Eli Collins commented on HDFS-1979:

This is really nice. I like how BackupNodeProtocol is explicit now and we can get rid of the
spool file. The new tests look good.

Should setStorageInfo also setBlockPoolID and setClusterID? Eg in BN#registerWith where we
call all three I'm wondering why those aren't a single method.

In FSIMage#getLastAppliedTxId why return editLog.getLastWrittenTxId()? It seems like this
method is for asking for the last tx from loading the image/edits log (a static property),
if someone wants the the last tx written to the edits log (dynamic) they should use that API

reloadFromImageFile is addressed in HDFS-2133, will comment there.

Why does LogLoadPlan() call super()?

* In rollForwardByApplyingLog brace is on it's own line
* In downloadEditsToStorage pull f onto prev line
* BackupNodeProtocol isAlive and startLogSegment need javadocs
* FSNamesystem#registerBackupNode params could use a comment/better names to distinguish which
registration is which (eg bnReg, nnReg)
* BN "Is journal spooling in progress" comment should be replaced with a new description.
Eg the state transition: DROP_UNTIL_NEXT_ROLL --> JOURNAL_ONLY <--> IN_SYNC

> HDFS-1073: Fix backupnode for new edits/image layout
> ----------------------------------------------------
>                 Key: HDFS-1979
>                 URL: https://issues.apache.org/jira/browse/HDFS-1979
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-1979-prelim.txt, hdfs-1979.txt, hdfs-1979.txt

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message