hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-1861) Rename dfs.datanode.max.xcievers and bump it's default value
Date Sun, 24 Apr 2011 21:48:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13024684#comment-13024684
] 

Todd Lipcon commented on HDFS-1861:
-----------------------------------

I don't think "receiver.threads" is correct - these threads are used for both writing and
reading blocks. max.transceiver.threads is probably a better name.

> Rename dfs.datanode.max.xcievers and bump it's default value
> ------------------------------------------------------------
>
>                 Key: HDFS-1861
>                 URL: https://issues.apache.org/jira/browse/HDFS-1861
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 0.23.0
>
>         Attachments: hdfs-1861-1.patch
>
>
> Reasonably sized jobs and HBase easily exhaust the current default for dfs.datanode.max.xcievers.
4096 works better in practice.
> Let's also deprecate it in favor of a more intuitive name, eg dfs.datanode.max.receiver.threads.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message