hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-1842) Cannot upgrade 0.20.203 to 0.21 with an editslog present
Date Tue, 19 Apr 2011 23:48:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1842?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13021859#comment-13021859
] 

Owen O'Malley commented on HDFS-1842:
-------------------------------------

+1 on the 203 patch.

> Cannot upgrade 0.20.203 to 0.21 with an editslog present
> --------------------------------------------------------
>
>                 Key: HDFS-1842
>                 URL: https://issues.apache.org/jira/browse/HDFS-1842
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: name-node
>    Affects Versions: 0.20.203.0
>            Reporter: Allen Wittenauer
>            Priority: Blocker
>         Attachments: HDFS-1842.rel203.patch, HDFS-1842.rel204.patch
>
>
> If a user installs 0.20.203 and then upgrades to 0.21 with an editslog present, 0.21
will corrupt the file system due to opcode re-usage.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message