hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-1861) Rename dfs.datanode.max.xcievers and bump its default value
Date Wed, 27 Apr 2011 16:14:03 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13025871#comment-13025871
] 

Aaron T. Myers commented on HDFS-1861:
--------------------------------------

Apologies for showing up to this JIRA late, but this JIRA seems like a good opportunity to
have added this config to {{hdfs-default.xml}}, with a helpful description. Changing the name
of it is good, but I believe there's still no documentation about it.

> Rename dfs.datanode.max.xcievers and bump its default value
> -----------------------------------------------------------
>
>                 Key: HDFS-1861
>                 URL: https://issues.apache.org/jira/browse/HDFS-1861
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 0.22.0, 0.23.0
>
>         Attachments: hdfs-1861-1.patch, hdfs-1861-2.patch
>
>
> Reasonably sized jobs and HBase easily exhaust the current default for dfs.datanode.max.xcievers.
4096 works better in practice.
> Let's also deprecate it in favor of a more intuitive name, eg dfs.datanode.max.receiver.threads.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message