hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Kelly (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-1538) Refactor more startup and image loading code out of FSImage
Date Tue, 29 Mar 2011 09:29:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1538?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13012406#comment-13012406
] 

Ivan Kelly commented on HDFS-1538:
----------------------------------

I just made a first pass. Line number are from the on-branch patch applied to HDFS-1073 branch.

I assume that you'll create a FSImageTransactionalStorageInspector or similar for HDFS-1073?

FSImage.java:542  
Line exceeds 80 chars. Why not do latestNameSD.read at the end of doRecovery() and get rid
of getStorageDirectoryForProperties() altogether?

FSImage.java:548  
I don't think it is. The previous command takes care of editsVersion!=LAYOUT_VERSION, and
imageVersion!=LAYOUT_VERSION shouldn't cause issues anyhow, as we always have to be able to
load from old layout versions. 

FSImage.java:562 & FSImage.java:576
Its nonobvious where this checkpoint id is coming from here. I think it would be clearer for
loadFSImage to return the last txid it loaded and then pass that as a parameter to loadEdits(List<File>
editLogs, long fromTxid).

FSImageStorageInspector.java: Javadocs are exceeding 80 chars
FSImageStorageInspector.java:61
Is ImageLoadPlan the best name for this given that it loads Edits also. Why not just LoadPlan?

FSImageOldStorageInspector.java: Some lines exceed 80 chars
FSImageOldStorageInspector.java:47 
You should create the logger with FSImageOldStorageInspector so that it's clear which inspector
is logging.


> Refactor more startup and image loading code out of FSImage
> -----------------------------------------------------------
>
>                 Key: HDFS-1538
>                 URL: https://issues.apache.org/jira/browse/HDFS-1538
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>    Affects Versions: Edit log branch (HDFS-1073)
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>             Fix For: Edit log branch (HDFS-1073)
>
>         Attachments: hdfs-1538-1.txt, hdfs-1538-2.txt, hdfs-1538-on-1521.txt, hdfs-1538-on-branch.txt,
hdfs-1538.txt
>
>
> For HDFS-1073, we need to be able to continue to load images in the old "fsimage/edits/edits.new"
layout for the purposes of upgrade.  But that code will be only for backwards compatibility,
and we want to be able to switch to new code for the new layout. This subtask is to separate
out much of that code into an interface which we can implement for both the old and new layouts.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message