hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-1674) HDFS Federation: Rename BlockPool class to BlockPoolSlice
Date Wed, 02 Mar 2011 00:11:37 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1674?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13001202#comment-13001202

Suresh Srinivas commented on HDFS-1674:

+1 for the patch.

> HDFS Federation: Rename BlockPool class to BlockPoolSlice 
> ----------------------------------------------------------
>                 Key: HDFS-1674
>                 URL: https://issues.apache.org/jira/browse/HDFS-1674
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node
>    Affects Versions: Federation Branch
>            Reporter: Tanping Wang
>            Assignee: Tanping Wang
>            Priority: Minor
>             Fix For: Federation Branch
>         Attachments: HDFS-1674.patch
> HDFS Federation (porting):
> The class BlockPool is poorly named as it does not represent an actual BlockPool, but
rather that slice of the overall BlockPool for which a single DataNode is responsible.  Renames
BlockPool, BlockPoolStorage, BlockPoolScanner to BlockPoolSlice*.  Moves BlockPookSlice out
of FSDataSet to a stand-alone class.  Updates references to these structures.  Other references
to BlockPools seem appropriate in the context of the code.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message