hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-1473) Refactor storage management into separate classes than fsimage file reading/writing
Date Thu, 02 Dec 2010 22:36:11 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12966317#action_12966317

Todd Lipcon commented on HDFS-1473:

Hi Konstantin. Thanks for the review. I fixed points 1 through 4 but disagree on point 5.
Will upload the patch momentarily.

bq. FSImageSerialization.TL_DATA is the new name for former FSImage.FILE_PERM

This isn't quite true. TL_DATA is now a struct which includes both FILE_PERM and the static
U_STR object which used to be incorrectly non-threadlocal. Sorry to have included the bug
fix in the refactor patch, but while I was moving U_STR anyway I figured it was a good idea
to address the issue.

So, TlData/TL_DATA themselves are descriptive of what they are - simply a container for thread-local
data. The members of this struct are named as they were before. If it weren't thread local
we wouldn't need this struct at all, and it would cease to exist.

> Refactor storage management into separate classes than fsimage file reading/writing
> -----------------------------------------------------------------------------------
>                 Key: HDFS-1473
>                 URL: https://issues.apache.org/jira/browse/HDFS-1473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>             Fix For: 0.22.0, 0.23.0
>         Attachments: hdfs-1473-prelim.txt, hdfs-1473.txt, hdfs-1473.txt, hdfs-1473.txt
> Currently the FSImage class is responsible both for storage management (eg moving around
files, tracking file names, the VERSION file, etc) as well as for the actual serialization
and deserialization of the "fsimage" file within the storage directory.
> I'd like to refactor the loading and saving code into new classes. This will make testing
easier and also make the major changes in HDFS-1073 easier to understand.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message