hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HDFS-1473) Refactor storage management into separate classes than fsimage file reading/writing
Date Thu, 18 Nov 2010 01:27:14 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1473?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Todd Lipcon updated HDFS-1473:
------------------------------

    Attachment: hdfs-1473-prelim.txt

Here's a super-preliminary patch for this. I moved around the bulk of the stuff that had to
move, but there are still some things that need some real cleanup plus new javadoc. For example,
there are currently 6 constructors used for FSImage which get pretty messy, since we now have
a {{conf}} member.

Just wanted to upload the patch to get comments if the general division of classes seems reasonable

> Refactor storage management into separate classes than fsimage file reading/writing
> -----------------------------------------------------------------------------------
>
>                 Key: HDFS-1473
>                 URL: https://issues.apache.org/jira/browse/HDFS-1473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-1473-prelim.txt
>
>
> Currently the FSImage class is responsible both for storage management (eg moving around
files, tracking file names, the VERSION file, etc) as well as for the actual serialization
and deserialization of the "fsimage" file within the storage directory.
> I'd like to refactor the loading and saving code into new classes. This will make testing
easier and also make the major changes in HDFS-1073 easier to understand.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message