hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-1473) Refactor storage management into separate classes than fsimage file reading/writing
Date Sun, 28 Nov 2010 20:57:38 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12964587#action_12964587
] 

Eli Collins commented on HDFS-1473:
-----------------------------------

Hey Todd,

Looks great.   

Why do we no longer assert the return value of getLayoutVersion() is negative in loadFSImage?
 This can be handled in a follow on change, if necessary.

Mind filing a jira for the cleanup you suggest in the TODO in the FSImage contructor?

Thanks,
Eli


> Refactor storage management into separate classes than fsimage file reading/writing
> -----------------------------------------------------------------------------------
>
>                 Key: HDFS-1473
>                 URL: https://issues.apache.org/jira/browse/HDFS-1473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-1473-prelim.txt, hdfs-1473.txt, hdfs-1473.txt, hdfs-1473.txt
>
>
> Currently the FSImage class is responsible both for storage management (eg moving around
files, tracking file names, the VERSION file, etc) as well as for the actual serialization
and deserialization of the "fsimage" file within the storage directory.
> I'd like to refactor the loading and saving code into new classes. This will make testing
easier and also make the major changes in HDFS-1073 easier to understand.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message