hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HDFS-1055) Improve thread naming for DataXceivers
Date Wed, 17 Nov 2010 00:55:15 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1055?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eli Collins resolved HDFS-1055.
-------------------------------

      Resolution: Fixed
        Assignee: Todd Lipcon
    Hadoop Flags: [Reviewed]

I've committed this.  Thanks Todd and Ramkumar!

> Improve thread naming for DataXceivers
> --------------------------------------
>
>                 Key: HDFS-1055
>                 URL: https://issues.apache.org/jira/browse/HDFS-1055
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>    Affects Versions: 0.22.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: dataxceiver-merged.patch, dataxceiver.patch, hdfs-1055-1.patch,
hdfs-1055-branch20.txt
>
>
> The DataXceiver threads are named using the default Daemon naming, which is Runnable.toString().
Currently this isn't implemented, so threads have names like org.apache.hadoop.hdfs.server.datanode.DataXceiver@579c9a6b.
It would be very handy for debugging (and even ops maybe) to have a better name like "DataXceiver
for client 1.2.3.4 [reading block_234254242]"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message