hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HDFS-1473) Refactor storage management into separate classes than fsimage file reading/writing
Date Thu, 18 Nov 2010 23:11:15 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1473?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Todd Lipcon updated HDFS-1473:

    Attachment: hdfs-1473.txt

Here's a patch that's been cleaned up and javadocced. I took Hairong's suggestion to combine
the loader and saver as inner classes in an FSImageFormat class.

As for making the FSNamesystem a member of that class instead of a parameter, it doesn't seem
to have an advantage or disadvantage, so left as is. I think as we clean this up more with
the other ongoing refactors it'll become clear which of the two is better and we can make
the change then.

We can continue to improve on this, but since these refactors cause lots of conflicts, I think
it's best to treat this as "final" for this issue and then do some more improvements in followup
commits. As is, I think it's better than it was before :)

> Refactor storage management into separate classes than fsimage file reading/writing
> -----------------------------------------------------------------------------------
>                 Key: HDFS-1473
>                 URL: https://issues.apache.org/jira/browse/HDFS-1473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-1473-prelim.txt, hdfs-1473.txt
> Currently the FSImage class is responsible both for storage management (eg moving around
files, tracking file names, the VERSION file, etc) as well as for the actual serialization
and deserialization of the "fsimage" file within the storage directory.
> I'd like to refactor the loading and saving code into new classes. This will make testing
easier and also make the major changes in HDFS-1073 easier to understand.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message