hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-1473) Refactor storage management into separate classes than fsimage file reading/writing
Date Thu, 18 Nov 2010 07:16:14 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12933338#action_12933338
] 

Todd Lipcon commented on HDFS-1473:
-----------------------------------

How about FSImageFormat, with two inner static classes, Loader and Writer? I like keeping
them as "one-shot" classes where the member variables are set by the loading/writing and then
can be fetched. This makes it easy to understand which members are results of writing vs results
of reading.

> Refactor storage management into separate classes than fsimage file reading/writing
> -----------------------------------------------------------------------------------
>
>                 Key: HDFS-1473
>                 URL: https://issues.apache.org/jira/browse/HDFS-1473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>         Attachments: hdfs-1473-prelim.txt
>
>
> Currently the FSImage class is responsible both for storage management (eg moving around
files, tracking file names, the VERSION file, etc) as well as for the actual serialization
and deserialization of the "fsimage" file within the storage directory.
> I'd like to refactor the loading and saving code into new classes. This will make testing
easier and also make the major changes in HDFS-1073 easier to understand.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message