hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-1055) Improve thread naming for DataXceivers
Date Wed, 17 Nov 2010 00:53:19 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12932739#action_12932739
] 

Eli Collins commented on HDFS-1055:
-----------------------------------

{noformat}
     [exec] 
     [exec] -1 overall.  
     [exec] 
     [exec]     +1 @author.  The patch does not contain any @author tags.
     [exec] 
     [exec]     -1 tests included.  The patch doesn't appear to include any new or modified
tests.
     [exec]                         Please justify why no new tests are needed for this patch.
     [exec]                         Also please list what manual steps were performed to verify
this patch.
     [exec] 
     [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
     [exec] 
     [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler
warnings.
     [exec] 
     [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
     [exec] 
     [exec]     -1 release audit.  The applied patch generated 103 release audit warnings
(more than the trunk's current 1 warnings).
     [exec] 
     [exec]     +1 system test framework.  The patch passed system test framework compile.
     [exec] 
{noformat}

Ran the tests, no additional tests are failing that aren't already failing on trunk. I verified
via jstack that the thread names are as intended, eg:

DataXceiver for client /127.0.0.1:41506 [Receiving block blk_2636278219925072830_1001 client=DFSClient_-283453089]"
daemon prio=10 tid=0x00007f42b0205000 nid=0x399f runnable [0x00007f42bc147000]

> Improve thread naming for DataXceivers
> --------------------------------------
>
>                 Key: HDFS-1055
>                 URL: https://issues.apache.org/jira/browse/HDFS-1055
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>    Affects Versions: 0.22.0
>            Reporter: Todd Lipcon
>         Attachments: dataxceiver-merged.patch, dataxceiver.patch, hdfs-1055-1.patch,
hdfs-1055-branch20.txt
>
>
> The DataXceiver threads are named using the default Daemon naming, which is Runnable.toString().
Currently this isn't implemented, so threads have names like org.apache.hadoop.hdfs.server.datanode.DataXceiver@579c9a6b.
It would be very handy for debugging (and even ops maybe) to have a better name like "DataXceiver
for client 1.2.3.4 [reading block_234254242]"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message