hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakob Homan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HDFS-1456) Provide builder for constructing instances of MiniDFSCluster
Date Thu, 14 Oct 2010 00:59:34 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1456?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jakob Homan updated HDFS-1456:
------------------------------

    Attachment: HDFS-1456.patch

Patch creates a new Builder class for construction MiniDFSClusters.  What before was:
{noformat}    cluster = new MiniDFSCluster(0, conf, NUM_DATA_NODES, true, false, true, null,
                                  null, null, null);{noformat}
can now be expressed as
{noformat}    cluster = new MiniDFSCluster.Builder(conf)
                                .numDataNodes(NUM_DATA_NODES)
                                .manageNameDfsDirs(false).build();{noformat}

I've converted a few instances to the new Builder.  If people like this idea, I'll convert
the rest, mainly through automation to avoid human error, but I wanted an easy-to-read patch
before one filled with auto-refactoring.  We can deprecate the MiniDFSConstructors as well.

> Provide builder for constructing instances of MiniDFSCluster
> ------------------------------------------------------------
>
>                 Key: HDFS-1456
>                 URL: https://issues.apache.org/jira/browse/HDFS-1456
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.22.0
>            Reporter: Jakob Homan
>            Assignee: Jakob Homan
>             Fix For: 0.22.0
>
>         Attachments: HDFS-1456.patch
>
>
> Time to fix a broken window. Of the 293 occurences of "new MiniDFSCluster("... most look
something like:
> {noformat}cluster = new MiniDFSCluster(0, config, numDatanodes, true, false, true,  null,
null, null, null);{noformat}
> The largest constructor takes 10 parameters, and even the overloaded constructors can
be difficult to read as their mainaly nulls or booleans.
> We should provide a Builder for constructing MiniDFSClusters to improve readability.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message