hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HDFS-1160) Improve some FSDataset warnings and comments
Date Thu, 27 May 2010 00:23:36 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1160?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eli Collins updated HDFS-1160:
------------------------------

    Attachment: hdfs-1160-3.patch

Patch attached, consolidates cleanup from HDFS-1161 with the current patch:
* Fixed some typos in logs eg "chek"
* Renamed variables like dp_error to dpError, ones like "fsvs" to more readable ones
* Adds warning in the case there's an exception reporting a disk error, currently ignored.
* Adds some missing javadocs
* Rewrote some loops that used indices to use the new for syntax, easier to follow

> Improve some FSDataset warnings and comments
> --------------------------------------------
>
>                 Key: HDFS-1160
>                 URL: https://issues.apache.org/jira/browse/HDFS-1160
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>    Affects Versions: 0.21.0, 0.22.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 0.21.0, 0.22.0
>
>         Attachments: hdfs-1160-1.patch, hdfs-1160-2.patch, hdfs-1160-3.patch
>
>
> The warning in FSDataset that prints "removing block" is more clear as "Removing replica
info for block" since the DN is not actually removing the block. The attached patch also cleans
up and fixes typos in some related comments and code. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message