hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sanjay Radia (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-1077) namenode RPC protocol method names are overloaded
Date Mon, 05 Apr 2010 22:24:27 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1077?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12853564#action_12853564
] 

Sanjay Radia commented on HDFS-1077:
------------------------------------

We can rename them as they are not public.
So short term we are fine.

However, if a server implements multiple independent RPC protocols, then we cannot require
their method names to not conflict. Is this solvable with Avro RPC? Aren't the method name
prefixed by the protocol name?

> namenode RPC protocol method names are overloaded
> -------------------------------------------------
>
>                 Key: HDFS-1077
>                 URL: https://issues.apache.org/jira/browse/HDFS-1077
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: name-node
>            Reporter: Doug Cutting
>            Assignee: Doug Cutting
>
> Avro RPC does not permit two different messages with the same name.  Several namenode
RPC protocol method names are overloaded.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message