hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "dhruba borthakur (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-531) Renaming of configuration keys
Date Thu, 27 Aug 2009 05:54:59 GMT

    [ https://issues.apache.org/jira/browse/HDFS-531?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12748266#action_12748266

dhruba borthakur commented on HDFS-531:

> dfs.max.replication.streams and dfs.heartbeat.recheck.interval should have a more specific
context? dfs.namenode.*?

I like this idea. Does it mean that we have dfs.namenode.* dfs.client.* and dfs.datanode.*
types of property names?

> Renaming of configuration keys
> ------------------------------
>                 Key: HDFS-531
>                 URL: https://issues.apache.org/jira/browse/HDFS-531
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Jitendra Nath Pandey
>            Assignee: Jitendra Nath Pandey
>             Fix For: 0.21.0
>         Attachments: changed_config_keys.txt
> Keys in configuration files should be standardized so that key names reflect the components
they are used in.
> For example:
>    dfs.backup.address should be renamed to dfs.namenode.backup.address 
>    dfs.data.dir   should be renamed to dfs.datanode.data.dir
> This change will impact both hdfs and common sources.
> Following convention is proposed:
> 1. Any key related hdfs should begin with 'dfs'.
> 2. Any key related to namenode, datanode or client should begin with dfs.namenode, dfs.datanode
or dfs.client respectively.  

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message