hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-530) Refactor TestFileAppend* to remove code duplications
Date Fri, 07 Aug 2009 12:54:14 GMT

    [ https://issues.apache.org/jira/browse/HDFS-530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12740534#action_12740534
] 

Hudson commented on HDFS-530:
-----------------------------

Integrated in Hadoop-Hdfs-trunk #42 (See [http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/42/])
    . Refactor TestFileAppend* to remove code duplication.  Contributed by Konstantin Boudnik


> Refactor TestFileAppend* to remove code duplications
> ----------------------------------------------------
>
>                 Key: HDFS-530
>                 URL: https://issues.apache.org/jira/browse/HDFS-530
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: test
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
>             Fix For: 0.21.0
>
>         Attachments: HDFS-530.patch, HDFS-530.patch, HDFS-530.patch
>
>
> Clearly, TestFileAppend* were created in a copy-cat mode which produces a number of duplications.
> As more tests for the new append feature are going to be developed, I'd like to get rid
of these duplications and allow some a better code reuse. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message