hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Boudnik (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HDFS-530) Refactor TestFileAppend* to remove code duplications
Date Wed, 05 Aug 2009 21:11:14 GMT

     [ https://issues.apache.org/jira/browse/HDFS-530?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Konstantin Boudnik updated HDFS-530:

    Attachment: HDFS-530.patch

- few common methods are moved to AppendTestUtil class to reduce code duplication; side effects
in some methods are replaced with adequate return types
- some common declarations are moved to AppendTestUtil and converted to constants
- a potential synchronization problem is addressed by declaring a synchronized object {{final}}
-  ArrayList<Path> testFiles = new ArrayList<Path>();
+  final ArrayList<Path> testFiles = new ArrayList<Path>();
- JavaDoc warnings are fixed
- code redundancies are fixed here and there. I.e. 
-                   dataset.detachBlock(b, 1) == false);
+            !dataset.detachBlock(b, 1));
- a bit of performance optimization is done

> Refactor TestFileAppend* to remove code duplications
> ----------------------------------------------------
>                 Key: HDFS-530
>                 URL: https://issues.apache.org/jira/browse/HDFS-530
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: test
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
>         Attachments: HDFS-530.patch
> Clearly, TestFileAppend* were created in a copy-cat mode which produces a number of duplications.
> As more tests for the new append feature are going to be developed, I'd like to get rid
of these duplications and allow some a better code reuse. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message