hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-563) Simplify the codes in FSNamesystem.getBlockLocations(..)
Date Tue, 25 Aug 2009 18:59:59 GMT

    [ https://issues.apache.org/jira/browse/HDFS-563?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12747572#action_12747572
] 

Konstantin Shvachko commented on HDFS-563:
------------------------------------------

This is a very good idea to expose {{namenode}} functionality for tests via a {{Util}} class
rather than keeping public methods in the {{NameNode}} itself. Could you please add a JavaDoc
comment saying something like "This is a utility class to expose NameNode functionality for
unit tests."
In order to establish the right precedence it would be better to change parameter FSNamesystem
to NameNode in Util.getBlockLocations(). That way we will be able to make getNamesystem()
method package private down the road.

> Simplify the codes in FSNamesystem.getBlockLocations(..)
> --------------------------------------------------------
>
>                 Key: HDFS-563
>                 URL: https://issues.apache.org/jira/browse/HDFS-563
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>             Fix For: 0.21.0
>
>         Attachments: h563_20090821.patch
>
>
> There are un-used codes in FSNamesystem.getBlockLocations(..).  Also, some codes can
be moved to tests.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message