hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-530) Refactor TestFileAppend* to remove code duplications
Date Thu, 06 Aug 2009 00:49:14 GMT

    [ https://issues.apache.org/jira/browse/HDFS-530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12739846#action_12739846

Tsz Wo (Nicholas), SZE commented on HDFS-530:

For this issue, I think we only has to run the tests affected since this is a test code refactoring.

> Refactor TestFileAppend* to remove code duplications
> ----------------------------------------------------
>                 Key: HDFS-530
>                 URL: https://issues.apache.org/jira/browse/HDFS-530
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: test
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
>         Attachments: HDFS-530.patch, HDFS-530.patch
> Clearly, TestFileAppend* were created in a copy-cat mode which produces a number of duplications.
> As more tests for the new append feature are going to be developed, I'd like to get rid
of these duplications and allow some a better code reuse. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message