hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HDFS-508) Factor out BlockInfo from BlocksMap
Date Tue, 28 Jul 2009 21:42:14 GMT

    [ https://issues.apache.org/jira/browse/HDFS-508?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12736323#action_12736323
] 

Tsz Wo (Nicholas), SZE commented on HDFS-508:
---------------------------------------------

- There is already a getINode() in BlockInfo.  So getInode() is redundant.

- rename "setInode" to "setINode" and the method does not need to be public.
{code}
+  public void setInode(INodeFile inode) {
{code}

- The javadoc for ensureCapacity(..) has an extra *
{code}
+   *      * @return first free triplet index.
{code}

> Factor out BlockInfo from BlocksMap
> -----------------------------------
>
>                 Key: HDFS-508
>                 URL: https://issues.apache.org/jira/browse/HDFS-508
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: name-node
>    Affects Versions: 0.20.1
>            Reporter: Konstantin Shvachko
>            Assignee: Konstantin Shvachko
>             Fix For: 0.21.0
>
>         Attachments: BlockInfo.patch
>
>
> {{BlockInfo}} is a static subclass of {{BlocksMap}}. It is time to factor it out. We
will need this to extend {{BlockInfo}} to {{BlockInfoUnderConstruction}} so that it could
keep track of replica states until all of them are written to data-nodes.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message