hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HDFS-511) Redundant block searches in BlockManager.
Date Thu, 30 Jul 2009 21:39:14 GMT

     [ https://issues.apache.org/jira/browse/HDFS-511?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Konstantin Shvachko updated HDFS-511:

    Attachment: BlockManager.patch

Don't see any rational reasons to keep the old method in BlockManager, but here it is.
I had to rename it to {{findAndMarkBlockAsCorrupt()}} because if there are two methods with
the same name it would be unclear which method is actually called for a stored block.

> Redundant block searches in BlockManager.
> -----------------------------------------
>                 Key: HDFS-511
>                 URL: https://issues.apache.org/jira/browse/HDFS-511
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>    Affects Versions: 0.21.0
>            Reporter: Konstantin Shvachko
>            Assignee: Konstantin Shvachko
>             Fix For: 0.21.0
>         Attachments: BlockManager.patch, BlockManager.patch, BlockManager.patch
> Some searches for a block in {{blocksMap}} are redundant and should be eliminated.
> {{BlockManager.addStoredBlock()}} contain unnecessary explicit and hidden (inside {{markBlockAsCorrupt()}})
calls of {{blocksMap.getStoredBlock()}}.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message