hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Jones <mcu...@gmail.com>
Subject The command "hdfs dfsadmin -report" fails because of a "connection exception: java.net.ConnectException:
Date Thu, 04 Jan 2018 21:53:11 GMT
I have two Ubuntu 16.04 servers running open source Hadoop 3.0.  One is a
NameNode, and the other is a DataNode.   I have configured three .xml files
on both servers to establish a cluster.  The hduser on the NameNode can ssh
into the DataNode. I have configured a workers file on the NameNode.

On the NameNode server I run this: bash start-all.sh
On the DataNode I used the jps command before and after running the above
bash script on the NameNode.  This bash script on the NameNode starts the
services on the datanode.  I can tell because of the jps command's output.

On the NameNode I run this: "hdfs dfsadmin -report" but I get this:

"report: Call From NameNodeServer/10.10.10.10 to NameNodeServer:54310
failed on connection exception: java.net.ConnectException: Connection
refused; For more details see:
http://wiki.apache.org/hadoop/ConnectionRefused"

The /etc/hosts files of both servers have no entry for 127.0.0.1 nor one
for localhost.

My .xml files refer to the correct NameNode server. I could manually ping
it from both servers.  There is no firewall between the servers blocking
connectivity (as evidenced by start-all.sh successfully starting services).

The problem does not happen with two RedHat servers in the cluster.

What am I doing wrong with the two Ubuntu servers?  Is this a bug?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message