hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akira Ajisaka <aajis...@apache.org>
Subject Re: Upgrading minimum version of Maven to 3.1 from 3.0
Date Tue, 04 Apr 2017 05:02:29 GMT
As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
the latest version of Maven 3.0.x is quite old. (4 years ago)

We need to update dev-support/docker/Dockerfile to enable Maven 3.1+ for 
precommit Jenkins job.

Regards,
Akira

On 2017/04/03 18:49, Sunil G wrote:
> Hi Folks,
>
> Recently we were doing build framework up-gradation for Yarn Ui. In order
> to compile yarn-ui on various architectures, we were using
> frontend-maven-plugin 0.0.22 version.
> However build is failing in *ppc64le.* If we could use latest version of
> frontend-maven-plugin, we could resolve this error. (such as using 1.1
> version). But this requires maven version 3.1 minimum. YARN-6421 is
> tracking this issue, and we thought we can propose to upgrade to maven 3.1
>
> Kindly share your thoughts.
>
> Thanks
> + Sunil
>

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-dev-help@hadoop.apache.org


Mime
View raw message