hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akira Ajisaka <aajis...@apache.org>
Subject Re: Upgrading minimum version of Maven to 3.1 from 3.0
Date Thu, 06 Apr 2017 07:08:30 GMT
Based on the positive feedback from Junping, filed HADOOP-14285 for the 
update.
Discussion can continue in the JIRA.

Thanks,
Akira

On 2017/04/05 12:56, Akira Ajisaka wrote:
> Agreed to upgrade to 3.3+ and change the version only in trunk.
>
> -Akira
>
> On 2017/04/05 11:21, Sunil G wrote:
>> Thanks Akira and Junping.
>>
>> @Junping. Yes, we plan to change this only in trunk and new YARN UI is
>> available there.
>> I also feel that there is no issue in moving to a latest version such as
>> 3.3.
>>
>> + Sunil
>>
>> On Tue, Apr 4, 2017 at 11:35 PM Junping Du <jdu@hortonworks.com
>> <mailto:jdu@hortonworks.com>> wrote:
>>
>>     Thanks Sunil to bring it up. However, any reason not to go to latest
>>     version of maven (3.3+)? Even version 3.1 is quite old - released 3+
>>     years from now (please refer:
>>     https://archive.apache.org/dist/maven/binaries/).
>>     btw, I assume we only plan to change maven version on trunk given
>>     new YARN UI only merge to trunk branch. Isn't it?
>>
>>     Thanks,
>>
>>     Junping
>>     ________________________________________
>>     From: Akira Ajisaka <aajisaka@apache.org
>> <mailto:aajisaka@apache.org>>
>>     Sent: Monday, April 03, 2017 10:02 PM
>>     To: Sunil G; common-dev@hadoop.apache.org
>>     <mailto:common-dev@hadoop.apache.org>; hdfs-dev@hadoop.apache.org
>>     <mailto:hdfs-dev@hadoop.apache.org>; yarn-dev@hadoop.apache.org
>>     <mailto:yarn-dev@hadoop.apache.org>; mapreduce-dev@hadoop.apache.org
>>     <mailto:mapreduce-dev@hadoop.apache.org>
>>     Subject: Re: Upgrading minimum version of Maven to 3.1 from 3.0
>>
>>     As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
>>     the latest version of Maven 3.0.x is quite old. (4 years ago)
>>
>>     We need to update dev-support/docker/Dockerfile to enable Maven
>> 3.1+ for
>>     precommit Jenkins job.
>>
>>     Regards,
>>     Akira
>>
>>     On 2017/04/03 18:49, Sunil G wrote:
>>     > Hi Folks,
>>     >
>>     > Recently we were doing build framework up-gradation for Yarn Ui.
>>     In order
>>     > to compile yarn-ui on various architectures, we were using
>>     > frontend-maven-plugin 0.0.22 version.
>>     > However build is failing in *ppc64le.* If we could use latest
>>     version of
>>     > frontend-maven-plugin, we could resolve this error. (such as
>> using 1.1
>>     > version). But this requires maven version 3.1 minimum. YARN-6421 is
>>     > tracking this issue, and we thought we can propose to upgrade to
>>     maven 3.1
>>     >
>>     > Kindly share your thoughts.
>>     >
>>     > Thanks
>>     > + Sunil
>>     >
>>
>>     ---------------------------------------------------------------------
>>     To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
>>     <mailto:yarn-dev-unsubscribe@hadoop.apache.org>
>>     For additional commands, e-mail: yarn-dev-help@hadoop.apache.org
>>     <mailto:yarn-dev-help@hadoop.apache.org>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: common-dev-unsubscribe@hadoop.apache.org
> For additional commands, e-mail: common-dev-help@hadoop.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-dev-help@hadoop.apache.org


Mime
View raw message