hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-8982) Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
Date Thu, 27 Aug 2015 22:29:45 GMT
Zhe Zhang created HDFS-8982:
-------------------------------

             Summary: Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
                 Key: HDFS-8982
                 URL: https://issues.apache.org/jira/browse/HDFS-8982
             Project: Hadoop HDFS
          Issue Type: Improvement
          Components: namenode
    Affects Versions: 2.7.1
            Reporter: Zhe Zhang


Currently {{INodeFile}} provides both {{getFileReplication}} and {{getPreferredBlockReplication}}
interfaces. At the very least they should be renamed (e.g. {{getCurrentFileReplication}} and
{{getMaxConfiguredFileReplication}}), with clearer Javadoc.

I also suspect we are not using them correctly in all places right now.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message