hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-7988) Replace usage of ExactSizeInputStream with LimitInputStream.
Date Tue, 24 Mar 2015 22:24:53 GMT
Chris Nauroth created HDFS-7988:
-----------------------------------

             Summary: Replace usage of ExactSizeInputStream with LimitInputStream.
                 Key: HDFS-7988
                 URL: https://issues.apache.org/jira/browse/HDFS-7988
             Project: Hadoop HDFS
          Issue Type: Improvement
            Reporter: Chris Nauroth
            Priority: Minor


HDFS has a class named {{ExactSizeInputStream}} used in the protobuf translation layer.  This
class wraps another {{InputStream}}, but constraints the readable bytes to a specified length.
 The functionality is nearly identical to {{LimitInputStream}} in Hadoop Common, with some
differences in semantics regarding premature EOF.  This issue proposes to eliminate {{ExactSizeInputStream}}
in favor of {{LimitInputStream}} to reduce the size of the codebase.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message