hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Lamb (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-7550) Minor followon cleanups from HDFS-7543
Date Thu, 18 Dec 2014 23:20:13 GMT
Charles Lamb created HDFS-7550:

             Summary: Minor followon cleanups from HDFS-7543
                 Key: HDFS-7550
                 URL: https://issues.apache.org/jira/browse/HDFS-7550
             Project: Hadoop HDFS
          Issue Type: Sub-task
          Components: namenode
    Affects Versions: 2.7.0
            Reporter: Charles Lamb
            Priority: Minor

The commit of HDFS-7543 crossed paths with these comments:


in #mkdirs, you removed the final String srcArg = src. This should be left in. Many IDEs will
whine about making assignments to formal args and that's why it was put in in the first place.


#renameToInt, dstIIP (and resultingStat) could benefit from final's.


I'm not sure why you've moved the call to getINodesInPath4Write and checkXAttrChangeAccess
inside the writeLock.


The javadoc for the @param src needs to be changed to reflect that it's an INodesInPath, not
a String. Nit: it might be better to rename the INodesInPath arg from src to iip.

#getFileInfo4DotSnapshot is now unused since you in-lined it into #getFileInfo.

This message was sent by Atlassian JIRA

View raw message