hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keren Ouaknine <ker...@gmail.com>
Subject Re: HDFS issue
Date Tue, 25 Mar 2014 06:04:17 GMT
Issue solved. I configured eclipse with additional env variables and it
solved the error :)
Thanks.


On Mon, Mar 24, 2014 at 2:12 PM, Keren Ouaknine <kereno@gmail.com> wrote:

> Hello,
>
> I encounter an HDFS error running Pig from eclipse. The error doesn't
> occur when I run Pig from the command line, as I successfully connect to:
> *Connecting to hadoop file system at: hdfs://localhost:54310*
>
> However, trying to debug Pig's Main class from eclipse I get the following
> error:
> *2014-03-24 14:01:13,629 [main] INFO
>  org.apache.pig.backend.hadoop.executionengine.HExecutionEngine -
> Connecting to hadoop file system at: file:///*
> *2014-03-24 14:01:14,775 [main] ERROR org.apache.pig.PigServer - exception
> during parsing: Error during parsing. Failed to create DataStorage*
>
> I added to eclipse classpath an entry pointing to the conf file, and also
> made sure my environment variables in the Run configurations were set at
> follow:
> HADOOP_HOME=/home/kereno/Documents/hadoop/hadoop-1.2.0
> HADOOP_CONF_DIR=/home/kereno/Documents/hadoop/hadoop-1.2.0/conf
> HADOOPDIR=/home/kereno/Documents/hadoop/hadoop-1.2.0/conf
>
> Any clue what can be the problem?
>
> I added a screenshot of the error on:
> http://kereno.com/hdfs_error.jpg
>
>
> Thanks,
> Keren
>
> --
> Keren Ouaknine
> www.kereno.com
>



-- 
Keren Ouaknine
www.kereno.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message