hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-5860) Refactor INodeDirectory getDirectoryXFeature methods to use common getFeature helper method.
Date Fri, 31 Jan 2014 20:30:09 GMT
Chris Nauroth created HDFS-5860:
-----------------------------------

             Summary: Refactor INodeDirectory getDirectoryXFeature methods to use common getFeature
helper method.
                 Key: HDFS-5860
                 URL: https://issues.apache.org/jira/browse/HDFS-5860
             Project: Hadoop HDFS
          Issue Type: Improvement
          Components: namenode
    Affects Versions: HDFS ACLs (HDFS-4685)
            Reporter: Chris Nauroth
            Priority: Minor


The HDFS-4685 feature branch has introduced a helper method for getting an inode feature of
a particular class: {{INodeWithAdditionalFields#getFeature}}.  Currently, this is only called
by code related to ACLs, but we can also use the same method to reduce code duplication in
the various {{INodeDirectory}} methods that get different kinds of features.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message