hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shinichi Yamashita (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-5360) Improvement of usage message of renameSnapshot and deleteSnapshot
Date Mon, 14 Oct 2013 23:36:45 GMT
Shinichi Yamashita created HDFS-5360:
----------------------------------------

             Summary: Improvement of usage message of renameSnapshot and deleteSnapshot
                 Key: HDFS-5360
                 URL: https://issues.apache.org/jira/browse/HDFS-5360
             Project: Hadoop HDFS
          Issue Type: Improvement
          Components: snapshots
    Affects Versions: 3.0.0
            Reporter: Shinichi Yamashita
            Priority: Minor


When the argument of "hdfs dfs -createSnapshot" comamnd is inappropriate, it is displayed
as follows.

{code}
[hadoop@trunk ~]$ hdfs dfs -createSnapshot
-createSnapshot: <snapshotDir> is missing.
Usage: hadoop fs [generic options] -createSnapshot <snapshotDir> [<snapshotName>]
{code}

On the other hands, the commands of "-renameSnapshot" and "-deleteSnapshot" is displayed as
follows. And there are not kind for the user.

{code}
[hadoop@trunk ~]$ hdfs dfs -renameSnapshot
renameSnapshot: args number not 3: 0

[hadoop@trunk ~]$ hdfs dfs -deleteSnapshot
deleteSnapshot: args number not 2: 0
{code}

It changes "-renameSnapshot" and "-deleteSnapshot" to output the message which is similar
to "-createSnapshot".



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message