hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-5327) Rename StandbyException to FailoverException
Date Tue, 08 Oct 2013 22:38:42 GMT
Jing Zhao created HDFS-5327:

             Summary: Rename StandbyException to FailoverException
                 Key: HDFS-5327
                 URL: https://issues.apache.org/jira/browse/HDFS-5327
             Project: Hadoop HDFS
          Issue Type: Improvement
    Affects Versions: 3.0.0
            Reporter: Jing Zhao
            Assignee: Jing Zhao
            Priority: Minor

After HDFS-5291, client's RPC level can determine whether to retry the same server or failover
to another server based on the two types of exception:

# The new introduced RetriableException indicating that the server is temporarily unavailable
and clients can retry. 
# The old StandbyException indicating that clients can failover and try another server.

In this context, since the term "standby" only tells one scenario (active + standby), we may
want to rename the StandbyException to FailoverException to make it more generic. 

This message was sent by Atlassian JIRA

View raw message