hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Azuryy Yu <azury...@gmail.com>
Subject Re: collision in the naming of '.snapshot' directory between hdfs snapshot and hbase snapshot
Date Tue, 16 Apr 2013 02:33:45 GMT
This was caused by HDFS-4666<https://issues.apache.org/jira/browse/HDFS-4666>,
committed yesterday.

IMO, it will be in a good place fianlly if HDFS and HBASE all changed
naming convention.

.hdfs_snapshot and .hbase_snapshot would be better.

On Tue, Apr 16, 2013 at 10:13 AM, Ted Yu <yuzhihong@gmail.com> wrote:

> Hi,
> This afternoon Huned ad I discovered an issue while playing with HBase
> Snapshots on top of Hadoop's Snapshot branch (
> http://svn.apache.org/viewvc/hadoop/common/branches/HDFS-2802/).
> HDFS (built from HDFS-2802 branch) doesn't allow paths with .snapshot as a
> component while HBase tries to create paths with .snapshot as a component.
> This leads to issues in HBase, and one of HDFS or HBase needs to give up
> the .snapshot reserved keyword. HBase released Snapshots feature in 0.94.6
> (quite recently) and it may not be too late to change HBase to use a
> different path component in an upcoming new release.
> In HBase these path names are not user visible. If there is a deployment of
> 0.94.6, one could provide a migration tool that renames .snapshot to
> .hbase-snapshot or something to be able to move to the Snapshot release of
> Hadoop. On the other hand, .snapshot in HDFS is a user visible name and is
> a convention that is used by many file systems. It's a matter of
> familiarity with such path names that would help users in using HDFS
> snapshots.
> I am including the hdfs-dev in this email. Would appreciate if we could
> work together and come up with a solution.
> You can find sample output from hdfs command here:
> http://pastebin.com/bBqR4Fvr
> Cheers

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message