hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-3887) Remove redundant chooseTarget methods in BlockPlacementPolicy.java
Date Tue, 04 Sep 2012 03:59:08 GMT
Jing Zhao created HDFS-3887:
-------------------------------

             Summary: Remove redundant chooseTarget methods in BlockPlacementPolicy.java
                 Key: HDFS-3887
                 URL: https://issues.apache.org/jira/browse/HDFS-3887
             Project: Hadoop HDFS
          Issue Type: Improvement
    Affects Versions: 3.0.0
            Reporter: Jing Zhao
            Assignee: Jing Zhao
            Priority: Trivial


BlockPlacementPolicy.java contains multiple chooseTarget() methods with different parameter
lists. It is difficult to follow and understand the code since some chooseTarget methods only
have minor differences and some of them are only invoked by testing code. 

In this patch, I try to remove some of the chooseTarget methods and only keep three of them:
two abstract methods and the third one using BlockCollection as its parameter.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message